阿里云
1024开发者盛宴之Java专家问答专场
发表主题 回复主题
  • 839阅读
  • 1回复

【高危漏洞预警】CVE-2018-5711:PHP GD库拒绝服务漏洞

级别: 论坛编辑
发帖
6019
云币
11823


2018年01月22日,外国安全研究人员发现PHP环境存在拒绝服务漏洞,通过该漏洞,利用精心构造的GIF图片PoC触发PHP函数循环挂起,导致网站功能受到影响,从而影响服务不可用,目前PoC已公开,由于使用PHP语言开发的网站使用GD库实现上传图片功能(例如:会员账号头像、博客相册等功能),建议用户关注,并尽快开展查修复工作,防止业务受到影响。











受影响范围:







  • PHP 5 < 5.6.33版本



  • PHP 7.0 < 7.0.27版本



  • PHP 7.1 < 7.1.13版本



  • PHP 7.2 < 7.2.1版本







漏洞修复方案:







目前PHP官方已经发布最新版修复该漏洞,开发或运维人员可以下载手工更新。




提示:建议您在版本升级前使用ECS快照功能或其他备份方式做好数据备份工作,避免升级过程中发生意外。







更多详情请点击







如有任何问题,可随时通过工单或服务电话95187联系反馈。











阿里云盾应急响应中心

x
级别: 架构狮
发帖
1217
云币
1941
只看该作者 沙发  发表于: 01-31
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个