阿里云
阿里云多端小程序中小企业获客首选
发表主题 回复主题
  • 7792阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-15718:Apache Hadoop YARN NodeManager信息泄露漏洞

级别: 论坛版主
发帖
241
云币
478
近日,Apache Hadoop 大数据平台的YARN NodeManager爆出信息泄露漏洞,CVE编号CVE-2017-15718,攻击者可能获得应用密码。受影响版本Apache Hadoop 2.7.3及2.7.4,之前为cve-2016-3086提供的安全性修复是不完整的。 Lx0nLJ\  
g+ c*VmY  
YARN NodeManager 泄漏凭证存储提供程序的密码,该凭据由nodemanager用于 YARN应用。如果你使用credentialprovider功能加密密码并应用于nodemanager配置,nodemanager启动的任何容器都有可能获取加密密码,其他密码本身不直接暴露,建议用户关注并开展查工作。 ?QOU9"@+B  
7D6`1 &  
具体详情如下: +%JBr+1#\  

{R}F4k  
漏洞编号: ^_WR) F'K  
CVE-2017-15718 *N">93:  
漏洞名称: ,;$OaJFT  
Apache Hadoop YARN NodeManager信息泄露漏洞 [,o:nry'a  
官方评级: R}nvSerVb  
高危 a:BW*Hy{\  
漏洞描述: $.PRav  
在Apache Hadoop 2.7.3及2.7.4,为cve-2016-3086提供的安全性修复是不完整的。 YARN NodeManager 泄漏凭证存储提供程序的密码,该凭据由nodemanager用于 YARN应用。如果你使用credentialprovider功能加密密码并应用于nodemanager配置,nodemanager启动的任何容器都有可能获取加密密码,其他密码不受影响。 fiGTI}=P  
漏洞利用条件和方式: fN&,.UB^p  
通过PoC直接远程利用。 fVbjU1N  
PoC状态: pbH!u+DF  
已公开 K10G+'H^  
漏洞影响范围: U,Z\)+-R  
Hadoop 2.7.3, 2.7.4 c1#0o) q*7  
漏洞检测: m5K?oV@n  
开发人员检查是否使用了受影响版本范围内的Apache Hadoop版本。 ,!#Am13  
漏洞修复建议(或缓解措施): BEDkyz;:  
  • 目前官方已经发布安全版本,使用Apache Hadoop 2.7.3 和 2.7.4版本的用户请尽快升级2.7.5以上版本
  • 如果暂时无法升级,请设置的JCEKS文件权限,适当限制未经授权的用户访问。
V]7/hN-Y}  
提示:建议您在版本升级前做好测试工作,同时使用ECS快照功能做好数据备份工作。 pY31qhoZ.  
情报来源: /<rvaR  
EF0v!XW  
y]db]pP5  
[LYO'-g^F#  
IW~R{ ]6  
Z-iU7 O  
IMf|/a9-  
qM\ 2f<)  
$L*gtZ  
3=O [Q:8  
~KK} $iM  
'RjEdLrI  
*u},(4Qf  
wC1pfXa  
>h7(kj:  
\|PiQy*_?  
%2QGbnt_*  
.n8R%|C5  
wWl ?c  
[JOa^U=  
fn}E1w  
`B %%2p&  
7:4c\C0  
'O<b'}-A  
x@NfN*?/+i  
\e86'&  
T?8BAxC?K  
+7.|1x;C  
[ 此帖被正禾在2018-02-06 09:49重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
批量上传需要先选择文件,再选择上传
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个
      ×
      全新阿里云开发者社区, 去探索开发者的新世界吧!
      一站式的体验,更多的精彩!
      通过下面领域大门,一起探索新的技术世界吧~ (点击图标进入)