阿里云
阿里云飞天战略营全新发布
发表主题 回复主题
  • 10549阅读
  • 1回复

[安全漏洞公告专区]【高危事件预警】WebLogic Server WLS组件远程命令执行漏洞入侵挖矿事件

级别: 论坛版主
发帖
227
云币
443
2017年12月18日,阿里安全监测到WebLogic PoC入侵云服务进行挖矿的安全事件,经过紧急介入分析,发现和确认黑客正在利用 WebLogic 反序列化漏洞(CVE-2017-3248 )和 WebLogic WLS 组件漏洞(CVE-2017-10271)对企业使用WebLogic WLS组件的业务进行入侵并植入挖矿木马。 YVzK$k'3U  
E: %%Dm  
具体详情如下:   OLv(  
        
@0aUWG!k  
2'++G[z  
漏洞编号: sUA)I%Q!  
CVE-2017-3248 Z0x N9S  
CVE-2017-12071 %'P58  
漏洞名称: 6(wpf^br2  
WebLogic Server WLS组件远程命令执行漏洞 5dhRuc  
官方评级: h><;TAp  
高危 ]+oPwp;il  
漏洞描述: [!v:fj  
本次利用两个漏洞入侵并植入木马程序为比特币挖矿木马,但由于远程攻击者可利用该漏洞通过发送 HTTP 请求,获取目标服务器的控制权限,黑客可以利用此漏洞进行其他目的攻击非常容易。 )y8$-"D(it  
5}1cNp6@  
X)Kd'6zg  
使用WebLogic Server WLS组件的用户较少,整体全网风险并不高。 >2_J(vm>  
漏洞利用条件和方式: [IMa0qs'  
通过PoC直接远程利用。 D:%v((Ccw  
PoC状态: jn]{|QZ  
目前PoC已经在流行。 $g*|h G/{  
漏洞影响范围: Rj-<tR{  
  • Oracle WebLogic Server 10.3.6.0.0
  • Oracle WebLogic Server 10.3.3.0.0
  • Oracle WebLogic Server 12.1.3.0.0
  • Oracle WebLogic Server 12.2.1.1.0
  • Oracle WebLogic Server 12.2.1.2.0
J)66\h=  
漏洞检测: 2mI=V.X[&  
1.扫描http://ip_address:7001/wls-wsat 地址,具体端口根据实际情况修改。 9NVe>\s_  
2.如果 WebLogic 是安裝在默认目录,确定以下文件是否存在(具体文件路径以实际安装路径为准): A|jaWZM-  
  • /home/WebLogic/Oracle/Middleware/wlserver_10.3/server/lib/wls-wsat.war  
  • home/WebLogic/Oracle/Middleware/user_projects/domains/base_domain/servers/AdminServer/tmp/.internal/wls-wsat.war  
  • /home/WebLogic/Oracle/Middleware/user_projects/domains/base_domain/servers/AdminServer/tmp/_WL_internal/wls-wsat
KyDQ<Dq&  
3.检查主机日志中是否存在“cmd.exe”、“/bin/bash” ,如果存在,则表示服务器可能被入侵。 iN_G|w[d  
漏洞修复建议(或缓解措施): W0X?"Ms|a  
1.删除war包 7kHEY5s "  
根据实际环境路径和业务需求,删除WebLogic程序下列war包及目录 gVk_<;s  
rm -f/home/WebLogic/Oracle/Middleware/wlserver_10.3/server/lib/wls-wsat.war fk9FR^u  
rm -f/home/WebLogic/Oracle/Middleware/user_projects/domains/base_domain/servers/AdminServer/tmp/.internal/wls-wsat.war J-hP4t&x  
rm -rf/home/WebLogic/Oracle/Middleware/user_projects/domains/base_domain/servers/AdminServer/tmp/_WL_internal/wls-wsat <kt,aMw[*  
2.设置网络访问控制 $TWt[  
配置http://ip_address:7001/wls-wsat 网络访问控制策略,禁止外网可以直接访问。 ?~;G)5  
3.更新补丁和扫描: C;M.dd  
更新Oracle官方发布相关补丁,下载链接:http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html !|hv49!H  
3.检测和防御 Td}#o!4!  
阿里云态势感知已增加检测规则,支持入侵行为和漏洞检测,建议您开通态势感知(专业版以上版本)进行检测。 g6+}'MN:5  
: >4{m)  
#"=_GA^.{  
NFv9%$l-  
7 i,}F|#8  
* 3WK`9q  
BJ wPSKL  
noV]+1#"V  
_m#M^<0n  
`XS6t)!ik  
J[ du>1D  
1@im+R?a  
d\+smED  
22)2o lU  
9;NR   
g`k_o<'JC  
[ 此帖被正禾在2017-12-24 19:29重新编辑 ]
级别: 新人
发帖
1
云币
1
只看该作者 沙发  发表于: 2017-12-26
Re【高危事件预警】WebLogic Server WLS组件远程命令执行漏洞入侵挖矿事件
这个漏洞跟weblogic反序列化有什么具体的关系,为什么写是通过(CVE-2017-3248 )、(CVE-2017-10271)对WLS组件实现的入侵。有利用细节吗?谢谢分享。
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个