阿里云
发表主题 回复主题
  • 9200阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】CVE-2017–1000405:Linux内核的Huge Dirty COW权限提升漏洞

级别: 论坛版主
发帖
240
云币
472
2017年11月20日,Linux内核被爆出Huge Dirty COW漏洞,该漏洞是在去年发现的脏牛漏洞(CVE-2016–5195)尚未被完全修复而产生的新漏洞,该漏洞类型属于本地提权,非直接远程攻击,影响范围有限。 7xOrG],E  
具体详情如下: 54Baz  
  
]B<Hrnn  
漏洞编号: d2x|PpmH  
CVE-2017–1000405 [Pu~kiN  
漏洞名称: C NNyz$  
Linux内核的Huge Dirty COW权限提升漏洞 }D7q)_g=  
官方评级: Qn77ZpL:LJ  
中危 A&2)iQ  
漏洞描述: lglC1W-q  
问题出现在get_user_pages函数中。 该函数用于获取用户进程中虚拟地址后面的物理页面。 调用者在使用时必须指定在这些页面上执行的动作,从而内存管理器可以准备相应的页面。而当调用者在私有映射内的页面上执行写入操作时,页面可能需要经历COW(写时复制)循环 ——当新页面可写时会将原始“只读”页面复制到新页面,而原始页面可能是具有“特权”的,由此造成了该漏洞 0wLu*K5$4E  
漏洞利用条件和方式: Wh:SZa|  
本地提权利用。 T'cahkSw'O  
PoC状态: _U.D*f<3)  
未公开 X;7gh>Q'4  
漏洞影响范围: `5[d9z/6  
Linux Kernel版本为:2.6.38 - 4.14 J>YwMl  
阿里提供的Ubuntu、CentOS及RHEL 5/6/7发行版本由于未引入漏洞代码,不受此漏洞影响。 $T\z  
漏洞检测: M%dXy^e  
查看(cat) /sys/kernel/mm/下的transparent_hugepage目录enabled文件,显示[always]则会有影响 Hb KJ&^  
漏洞修复建议(或缓解措施): x?:[:Hf   
  • 本漏洞安全风险较低,升级内核风险较大,谨慎升级内核;
  • 关注官方发布的安全补丁。
-bo5/`x  
情报来源: b8QA>]6A  
  • https://medium.com/bindecy/huge-dirty-cow-cve-2017-1000405-110eca132de0
  • https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-1000405
  • http://www.openwall.com/lists/oss-security/2017/11/30/2
!_VKJZuH  
; /fZh:V2  
%X Jv;|  
JpEE'#r|  
fPf8hz>  
8F(lW)An  
1MH[-=[Q  
!>g_9'n'  
L'LZK  
<FIc!  
\`\& G-\  
JzJS?ZF  
>(s)S[\  
6fhH)]0  
[ 此帖被正禾在2017-12-01 17:49重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个