阿里云
发表主题 回复主题
  • 6591阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-16943/16944:开源邮件代理服务Exim远程执行命令和DOS漏洞

级别: 论坛版主
发帖
240
云币
472
2017年11月25日,Phil Pennock发布Exim新版本,其中包含一个修复漏洞释放漏洞,可导致远程执行代码(RCE),存在严重的安全风险。 $.,B2}'  
T9w=k)  
K&`1{,  
开源邮件传输代理Exim简介 ]q{_i   
Exim是由剑桥大学Philip Hazel开发的邮件传输代理,负责邮件的路由,转发和投递。它可运行在绝大多数的类Unix系统上,包括Solaris、AIX、Linux、macOS等。相比其他MTA,Exim配置更灵活,支持String Expansion技术,能执行诸如条件判断,字符转换等功能。 Sk>=C0f:  
iaEQF]*cC  
l;@+=uVDHm  
具体详情如下: ;]Q6K9.d8  
  
 jK]1X8  
漏洞编号: <6Gs0\JB  
CVE-2017-16943 "%Y=+  
CVE-2017-16944 C&H'?0Y@  
漏洞名称: jL^@;"/XhC  
开源邮件代理服务Exim远程执行命令和DOS漏洞 I ]ZZN6"  
官方评级: rY45.,qWs  
高危 U?:P7YWy  
漏洞描述: }8Y! -qX  
w=WF$)ZU  
CVE-2017-16943 px K&aY8  
通过构造一个BDAT命令序列就可被用于在SMTP服务器中远程执行任意代码。研究人员还公布了用Python编写的PoC利用代码,任何人均可在易受攻击的Exim服务器中执行代码。 v f{{z%3T  
CVE-2017-16944 }u O YF  
可导致远程攻击者在连接关闭的情况下通过强制其在不崩溃的情况下无限循环地运行将Exim服务器挂起。这个漏洞产生的原因是在解析BDAT数据头时未正确检查表示邮件结束的 ‘.’字符。研究人员还提供了PoC利用代码,导致Exim服务器耗尽栈并崩溃。 2wY|E<E  
漏洞利用条件和方式: b/:wpy+9Z  
通过PoC直接远程利用。 F6[F~^9D  
PoC状态: +:;ddV  
已公开 HbA/~7  
漏洞影响范围: Dc-K08c  
Exim 4.88 和 4.89 版本 '?veMX  
漏洞检测: Tt)z[^)%  
开发人员检查是否使用了受影响版本范围内的Exim。 [cd1Mf:[Y  
漏洞修复建议(或缓解措施): 0d_)C>gcF  
  • 在Exim的配置文件中,加上“chunking_advertise_hosts=”,也就是将chunking_advertise_hosts 的值设置为空,这样可以禁用ESMTP CHUNKING 扩展,使BDAT 不可用,从而避免被攻击者利用。
  • 目前官方已经发布新版本4.89.1 ,建议您及时更新。
CZ3oX#b  
情报来源: /o;L,mcx*  
I!Z`'1"  
5U47 5&  
M<w.q|P  
kPs?  
ct3i^,i  
JfN5#+_i  
XY'8oU`]{  
,w#lUg p  
[_)`G*X(N  
[ 此帖被正禾在2017-11-30 14:27重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: 阿里云官网域名是什么? 正确答案:www.aliyun.com
上一个 下一个