阿里云
发表主题 回复主题
  • 5055阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-16943/16944:开源邮件代理服务Exim远程执行命令和DOS漏洞

级别: 论坛版主
发帖
237
云币
465
2017年11月25日,Phil Pennock发布Exim新版本,其中包含一个修复漏洞释放漏洞,可导致远程执行代码(RCE),存在严重的安全风险。 %{*}KsS`p  
LB|FVNW/S  
h[SuuW  
开源邮件传输代理Exim简介 g_\U-pzr  
Exim是由剑桥大学Philip Hazel开发的邮件传输代理,负责邮件的路由,转发和投递。它可运行在绝大多数的类Unix系统上,包括Solaris、AIX、Linux、macOS等。相比其他MTA,Exim配置更灵活,支持String Expansion技术,能执行诸如条件判断,字符转换等功能。 ^h z4IZ^  
ceDe!Iu  
` gIlS^Q  
具体详情如下: 2-9'zN0u  
  
oGi;S="I  
漏洞编号: `b^eRnpR  
CVE-2017-16943 ]~:9b[G2  
CVE-2017-16944 HF9d~7R  
漏洞名称: R&13P&:g  
开源邮件代理服务Exim远程执行命令和DOS漏洞 )vB,eZq  
官方评级: f)p c$~B  
高危 UwuDs2 t  
漏洞描述: n%lY7.z8d  
w\ U fq  
CVE-2017-16943 Dz4fP;n  
通过构造一个BDAT命令序列就可被用于在SMTP服务器中远程执行任意代码。研究人员还公布了用Python编写的PoC利用代码,任何人均可在易受攻击的Exim服务器中执行代码。 =FkU: q$  
CVE-2017-16944 E"D+CD0  
可导致远程攻击者在连接关闭的情况下通过强制其在不崩溃的情况下无限循环地运行将Exim服务器挂起。这个漏洞产生的原因是在解析BDAT数据头时未正确检查表示邮件结束的 ‘.’字符。研究人员还提供了PoC利用代码,导致Exim服务器耗尽栈并崩溃。 :zk69P3  
漏洞利用条件和方式: FpjpsD~ Qu  
通过PoC直接远程利用。 sGjYL>*  
PoC状态: kK]JN  
已公开 i?uJ<BdU[  
漏洞影响范围: rmj?jBKQU  
Exim 4.88 和 4.89 版本 -AUdBG  
漏洞检测: PT7L65  
开发人员检查是否使用了受影响版本范围内的Exim。 u?[dy n  
漏洞修复建议(或缓解措施): -,NiSh}A  
  • 在Exim的配置文件中,加上“chunking_advertise_hosts=”,也就是将chunking_advertise_hosts 的值设置为空,这样可以禁用ESMTP CHUNKING 扩展,使BDAT 不可用,从而避免被攻击者利用。
  • 目前官方已经发布新版本4.89.1 ,建议您及时更新。
q| p6UL9  
情报来源: f S50  
\hpD  
K4]c   
Gma)8X#  
VU7x w  
bKsl'3~ k  
ViqcJD  
(,~gY=E+  
SV;S`\i  
T&6W>VQ|[>  
[ 此帖被正禾在2017-11-30 14:27重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: 阿里云官网域名是什么? 正确答案:www.aliyun.com
上一个 下一个