阿里云
云栖社区2017年度内容特辑
发表主题 回复主题
  • 1604阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-12149:JbossAS 5.x/6.x 反序列化命令执行漏洞

级别: 论坛版主
发帖
216
云币
402
2017年8月30日,Redhat公司发布了一个JBossAS 5.x系统的远程代码执行严重漏洞通告,相应的漏洞编号为CVE-2017-12149。近期有安全研究者发现JBossAS 6.x也受该漏洞影响,攻击者可能利用此漏洞无需用户验证在系统上执行任意命令。 7O"T `>  
具体详情如下: +y-:(aP  

<Qwi 0$  
漏洞编号: $|A vT;4  
CVE-2017-12149 Ph-3,cC  
漏洞名称: vn|X,1o  
JBossAS 5.x/6.x反序列化命令执行漏洞 ~~h9yvW7&  
官方评级: r Cmqq/hZ  
高危 F[~qgS*;  
漏洞描述: [rGR1>U?i  
该漏洞存在于JBossAS的HttpInvoker 组件中的ReadOnlyAccessFilter 过滤器中。该过滤器在没有进行任何安全检查的情况下尝试将来客户端的数据流进行反序列化,从而导致了漏洞。 k9Yr&8B  
漏洞利用条件和方式: R[o KhU  
通过PoC直接远程利用。 t XfB.[U  
PoC状态: I8?egDkk  
已公开 GY0<\-  
漏洞影响范围: EEF}Wf$f  
JBossAS 5.x/6.x 版本 k%uRG_  
漏洞检测: -BNW\ ]}  
开发人员检查是否使用了受影响版本范围内的JBossAS。 y:pypuwt;  
漏洞修复建议(或缓解措施): hydn" 9;  
  • 如业务不需要使用http-invoker.sar组件,建议直接删除该组件;
  • 手动添加以下代码至http-invoker.sar下web.xml的security-constraint标签中,对http invoker组件进行访问控制: <url-pattern style="box-sizing: border-box;">/*
Jb_/c``  
情报来源: yp!Xwq#n  
  • https://access.redhat.com/security/cve/cve-2017-12149
k98--kc5  
{jr>Z"/q  
>YPfk=0f0  
[ 此帖被正禾在2017-11-23 15:50重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个