阿里云
发表主题 回复主题
  • 5378阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】GNU Wget缓冲区溢出漏洞

级别: 论坛版主
发帖
240
云币
472
2017年10月26日,GNU Wget发布了1.19.2之前版本的缓冲区溢出漏洞公告,当使用存在漏洞的wget下载http特殊链接时,可能受到恶意HTTP响应攻击,导致拒绝服务和恶意代码执行,存在一定的安全风险,两个漏洞编号为:CVE-2017-13089、CVE-2017-13090 fQA)r  
具体详情如下:                                                                                                                                                  
漏洞编号: a7d-  
CVE-2017-13089 nMvIL2:3  
CVE-2017-13090 BRLU&@G`1  
漏洞名称: j/ IZm)\  
GNU Wget缓冲区溢出漏洞 j1CD;9i)%  
官方评级: pXlBKJmW  
中危 q5?mP6   
漏洞描述: tf79Gb>  
l"!;Vkg.5  
CVE-2017-13089 ojqX#>0K  
漏洞在src/http.c源码文件中,wget在一些调用http.c:skip_short_body() 函数情况下,块解析器使用strtol() 读取每个响应分块的长度,但不检查块长度是否是非负数,而在wget调用过程中该数据内容和长度可以完全被攻击者控制,从而导致最终在fd_read()函数中触发栈缓冲区溢出。 s1apHwJ -  
&-Y:4.BXZ  
)_.H #|r  
CVE-2017-13090 R~(.uV`#j  
漏洞在src/retr.c源码文件中,wget在一些调用retr.c:fd_read_body()函数情况下,块解析器使用strtol() 读取每个响应分块的长度,但不检查块长度是否是非负数,而在wget调用过程中该数据内容和长度可以完全被攻击者控制,从而导致最终在fd_read()函数中触发堆缓冲区溢出。 ?qW|k6{O  
_ILOA]ga#  
| N,nt@~  
漏洞利用条件和方式: `8bp6}OD,  
本地利用可以造成拒绝服务。 ,$[lOFs  
通过使用wget下载http链接的业务场景,可能会造成命令执行。 J(VZa_  
PoC状态: x G"p .  
已公开了PoC测试代码 F RUt}*  
漏洞影响范围: <Y6>L};  
GNU Wget <1.19.2版本 78#ud15Ml  
1.Redhat TrA Uu`?#  
不受影响:Redhat 5、6 Gukq}ZQd  
受影响:Redhat 7 $&C%C\(>D  
2.Ubuntu: >Cc$ P  
Ubuntu 12、14、16均受到影响,目前已经发布补丁。 U]3JCZ{]0E  
3.Debain: ;<rJ,X#  
均受到影响。 qT%E[qDS  
4.CentOS: $MGd>3%y  
CentOS 7受到此漏洞影响。 Q+N @j]'  
5.SUSE: svgi!=  
SUSE Linux Enterprise Server 11不受此漏洞影响,其他版本均受此漏洞影响 (dZ&Af  
漏洞检测: fE}}>  
开发或运维人员使用“wget -V”命令是否使用了受影响版本范围内的Wget。 x7>sy,c  
漏洞修复建议(或缓解措施): AkC\CdmA  
  • 目前漏洞细节和测试代码已经公开,各大操作系统发行厂商均已经发布补丁,为了防止发生安全事件,阿里安全提醒您建议升级到最新版本;
  • 阿里云云盾安骑士支持该漏洞检测和修复,建议您开启自动化检测。
}]@ "t)"  
情报来源: ?yh.*,dgi  
  • https://www.viestintavirasto.fi/en/cybersecurity/vulnerabilities/2017/haavoittuvuus-2017-037.html
  • Red Hat Enterprise Linux 7
https://access.redhat.com/security/cve/CVE-2017-13089 D1a2|^zt  
https://access.redhat.com/security/cve/CVE-2017-13090
  • SUSE(SUSE Linux Enterprise Server/openSUSE)
https://www.suse.com/security/cve/CVE-2017-13089/ Yuck]?#0  
https://www.suse.com/security/cve/CVE-2017-13090/
  • Debian
https://security-tracker.debian.org/tracker/CVE-2017-13089 0\A[a4crj  
https://security-tracker.debian.org/tracker/CVE-2017-13090 tO$M[P=b  
Found in versions wget/1.16-1, wget/1.19.1-5 a r%Rr"  
Fixed in versions 1.16-1+deb8u4, 1.18-5+deb9u1, wget/1.19.2-1
  • Ubuntu
https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-13089.html SOJHw6  
https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-13090.html g5`YUr+3?h  
https://usn.ubuntu.com/usn/usn-3464-1/ 5j %jhby?  
https://usn.ubuntu.com/usn/usn-3464-2/ vzPrG%Uu7g  
  • Gentoo
https://bugs.gentoo.org/show_bug.cgi?id=CVE-2017-13089 :-n4! z"k  
https://bugs.gentoo.org/show_bug.cgi?id=CVE-2017-13090
  • CentOS
https://lists.centos.org/pipermail/centos-announce/2017-October/022609.html Fx2&ji6u  
  • FreeBSD
https://reviews.freebsd.org/rP453520 (>'d`^kjk  
$ :/1U$  
,P]{*uqGiB  
Wit1WI;18  
n&lLC&dL  
_Yv9u'q"  
eyOAG4QTV  
DzMkeX  
?g2K&  
+{&g|V  
ZO}*^  
Rp1OC  
oz--gA:g  
[iz  
LBzpaLd  
O`4X[r1LD  
W\/0&H\i  
dpS  
) PtaX|U  
snrfHDhUw  
0Pe.G0 #  
ZsE8eD  
x<"e  
?hO*~w;UU|  
UqH7ec  
 dbR4%;<  
q\\J9`Q$J  
"D+QT+sD  
'W)x<Iey1  
6 J#C  
DWDe5$^{  
V&G_Bu~  
Adh CC13B  
hd900LA}  
*i|hcDk  
p^2pv{by  
w ^A0l.{  
_=rXaTp  
BJvVZl2h  
CZ @M~Si_  
j \SDw  
~"(1~7_  
7+0hIKrFC  
]uP {Sj  
{^~{X$YI  
:]x)lP(3E  
.UJk0%1  
YO=;)RA  
lps  
q,2 @X~T  
t.m $|M>  
; qvZ*  
?p`}6s Q}  
i+2J\.~U#G  
r/PsFv{8  
H94$Xi"Bd  
\4V'NTjB  
[ 此帖被正禾在2017-11-13 08:46重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
批量上传需要先选择文件,再选择上传
 
验证问题: 71 + 5 = ?
上一个 下一个