阿里云
发表主题 回复主题
  • 3965阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】GNU Wget缓冲区溢出漏洞

级别: 论坛版主
发帖
233
云币
457
2017年10月26日,GNU Wget发布了1.19.2之前版本的缓冲区溢出漏洞公告,当使用存在漏洞的wget下载http特殊链接时,可能受到恶意HTTP响应攻击,导致拒绝服务和恶意代码执行,存在一定的安全风险,两个漏洞编号为:CVE-2017-13089、CVE-2017-13090 @gfDp<  
具体详情如下:                                                                                                                                                  
漏洞编号: j tA*pL'/V  
CVE-2017-13089 %{5n1w  
CVE-2017-13090 wz /GB8P  
漏洞名称: mY&ud>,U:  
GNU Wget缓冲区溢出漏洞 )j&"%[2F  
官方评级: F} DUEDND*  
中危 x4K`]Fvhl  
漏洞描述: -w 6 "?  
9IZu$-  
CVE-2017-13089 w YNloU  
漏洞在src/http.c源码文件中,wget在一些调用http.c:skip_short_body() 函数情况下,块解析器使用strtol() 读取每个响应分块的长度,但不检查块长度是否是非负数,而在wget调用过程中该数据内容和长度可以完全被攻击者控制,从而导致最终在fd_read()函数中触发栈缓冲区溢出。 ^4$ 'KIq  
+Ov2`O8?  
K%g;NW  
CVE-2017-13090 )@g;j>  
漏洞在src/retr.c源码文件中,wget在一些调用retr.c:fd_read_body()函数情况下,块解析器使用strtol() 读取每个响应分块的长度,但不检查块长度是否是非负数,而在wget调用过程中该数据内容和长度可以完全被攻击者控制,从而导致最终在fd_read()函数中触发堆缓冲区溢出。 P`SnavQBt  
 lhLGG  
`S/wJ'c  
漏洞利用条件和方式: w7kJg'X/6  
本地利用可以造成拒绝服务。 CnF |LTi  
通过使用wget下载http链接的业务场景,可能会造成命令执行。 pw020}`  
PoC状态: ?pGkk=,KB  
已公开了PoC测试代码 [J#1Ff;  
漏洞影响范围: HeN~c<NuB  
GNU Wget <1.19.2版本 12`_;[37  
1.Redhat m~l F`?  
不受影响:Redhat 5、6 U]4pA#*{|  
受影响:Redhat 7 Xa 9TS"  
2.Ubuntu: wsfd8T4  
Ubuntu 12、14、16均受到影响,目前已经发布补丁。 $.mQ7XDA9  
3.Debain: {U!uVQC'  
均受到影响。 !fkep=  
4.CentOS: P>Qpv Sd_#  
CentOS 7受到此漏洞影响。 `iShJz96  
5.SUSE: !Jfs?Hy  
SUSE Linux Enterprise Server 11不受此漏洞影响,其他版本均受此漏洞影响 h1"zV6U  
漏洞检测: hP@(6X,"  
开发或运维人员使用“wget -V”命令是否使用了受影响版本范围内的Wget。 (&\aA 0-}H  
漏洞修复建议(或缓解措施): /\d$/~BFi  
  • 目前漏洞细节和测试代码已经公开,各大操作系统发行厂商均已经发布补丁,为了防止发生安全事件,阿里安全提醒您建议升级到最新版本;
  • 阿里云云盾安骑士支持该漏洞检测和修复,建议您开启自动化检测。
] gb=  
情报来源: ;&;W T  
  • https://www.viestintavirasto.fi/en/cybersecurity/vulnerabilities/2017/haavoittuvuus-2017-037.html
  • Red Hat Enterprise Linux 7
https://access.redhat.com/security/cve/CVE-2017-13089 T~8  .9g  
https://access.redhat.com/security/cve/CVE-2017-13090
  • SUSE(SUSE Linux Enterprise Server/openSUSE)
https://www.suse.com/security/cve/CVE-2017-13089/ \>/M .2  
https://www.suse.com/security/cve/CVE-2017-13090/
  • Debian
https://security-tracker.debian.org/tracker/CVE-2017-13089 T6 #"8qz<  
https://security-tracker.debian.org/tracker/CVE-2017-13090 &~sfYW  
Found in versions wget/1.16-1, wget/1.19.1-5  q" @  
Fixed in versions 1.16-1+deb8u4, 1.18-5+deb9u1, wget/1.19.2-1
  • Ubuntu
https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-13089.html `(4pu6uT  
https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-13090.html BNGe exs@  
https://usn.ubuntu.com/usn/usn-3464-1/ ?>uew^$d[w  
https://usn.ubuntu.com/usn/usn-3464-2/ t` ^ Vb-  
  • Gentoo
https://bugs.gentoo.org/show_bug.cgi?id=CVE-2017-13089 -0HkTY  
https://bugs.gentoo.org/show_bug.cgi?id=CVE-2017-13090
  • CentOS
https://lists.centos.org/pipermail/centos-announce/2017-October/022609.html ;DRTQn`m  
  • FreeBSD
https://reviews.freebsd.org/rP453520 p#8W#t$  
@]CF&: P A  
wVK*P -C  
M@UVpQwgv  
wzcai 0y*  
D #2yIec  
rjA@U<o  
%Q|eiXD  
h5%|meZQb  
tV;% J4E'  
0&Gl@4oZ"  
 NY  
h+UnZfm  
f?fKhu2  
Y#V8(DTyH  
H3/caN:  
~fN%WZ;_  
eBW=^B"y+  
|!z2oO  
Q'NmSX)0  
FY0%XW  
Ibr%d2yS=  
q ojXrSb"y  
|cbd6e{!  
H -t|i  
~9o6 W",  
('k<XOi  
;6;H*Y0,|E  
z5cYyx r>  
n~0z_;5  
x!7yU_ls`  
`x8B n"  
t1]6(@mj5  
7ET jn)%bs  
5mB]N%rfW%  
nS.G~c|  
w<wV]F*  
 !rL<5L  
UGKaOol.  
, |E$'  
t%0?N<9YkU  
4cgIEw[6  
6 vs3O  
{ISE'GJj  
gSi5u# }J  
o+?@5zw -&  
gT52G?-  
b{[*N  
`iixq9xi  
RVM&4#E  
*o?i:LE]  
IM( u<c$  
APBK9ky  
{[#(w75R{  
v548ysE)  
f=:.BR{  
[1Dm<G u@  
[ 此帖被正禾在2017-11-13 08:46重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: 1 - 0 = ?
上一个 下一个