阿里云
发表主题 回复主题
  • 2306阅读
  • 5回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-9805:Struts2 REST插件远程执行命令漏洞(S2-052)

级别: 论坛版主
发帖
209
云币
390
2017年9月5日,Struts官方发布一个严重级别的安全漏洞,该漏洞编号为:S2-052,在一定条件下,攻击者可以利用该漏洞远程发送精心构造的恶意数据包,获取业务数据或服务权限,存在高安全风险。 .9h)bf+  
具体详情如下:                                                                                                                        
漏洞编号: {)@D`{$  
CVE-2017-9805 ?NG=8.p  
漏洞名称: SEM8`lnu  
Struts2 REST插件远程执行命令漏洞(S2-052) ~W03{9(Vp8  
官方评级: 6~8F!b2  
严重 Z\? E3j  
漏洞描述: 7I}P*%(f  
Struts2使用REST插件使用XStream的实例xstreamhandler处理反序列化XML有效载荷时没有进行任何过滤,可以导致远程执行代码,攻击者可以利用该漏洞构造恶意的XML内容获取服务器权限。 `8:Kp  
漏洞利用条件和方式: !tNd\ }@  
使用REST插件条件下 *(QH{!-$s  
漏洞影响范围: >7b)y  
  • Struts 2.3.x全系版本
  • Struts 2.5 - Struts 2.5.12
WVX`<  
漏洞检测: *1A&'T2  
开发人员检查Struts是否使用了REST插件,并在受影响范围内。 \+nGOvM  
漏洞修复建议(或缓解措施): /ty?<24ko  
  • 目前官方已经发布补丁,建议升级 Apache Struts 2.5.13、Apache Struts 2.3.34版本;
gfy19c 9  
  • 阿里云盾WAF 已发布该漏洞规则,您也可以选用WAF对利用该漏洞的攻击行为进行检测和防御,以规避安全风险。
2e1]}wlK  
情报来源: WE6\dhJ<  
  • https://cwiki.apache.org/confluence/display/WW/S2-052
TDNf)Mm  
osH Cg  
bwiD$  
1;lmu]I>)  
#X`8dnQZ  
M\D]ml~  
h#qN+qt}  
86qI   
UMMB0(0D  
h<6UC%'ac  
/ T c=  
6GL=)0Ah  
^3]UZ@  
q%/uQT?  
K@u&(}  
y\c"b-lQX  
D g>^ A  
v?:: |{  
<a^Oj LLU  
)R2XU  
m D58T2 Z  
+T{'V^  
X/0v'N  
,!#ccv+Vm%  
g"_C,XN  
:t("L-GPW  
[ 此帖被正禾在2017-09-07 21:43重新编辑 ]
级别: 新人
发帖
13
云币
18
只看该作者 沙发  发表于: 09-06
Re【漏洞公告】CVE-2017-9805Struts2 REST插件远程执行命令漏洞S2-052
大半夜被这熊孩子给折腾醒,不知道POC检测工具什么时候能出来。
级别: 论坛版主
发帖
209
云币
390
只看该作者 板凳  发表于: 09-06
回 1楼(送小孩) 的帖子
POC已经公开了,尽快升级吧!
级别: 新人
发帖
13
云币
18
只看该作者 地板  发表于: 09-07
Re【漏洞公告】CVE-2017-9805Struts2 REST插件远程执行命令漏洞S2-052
S2-053   又双叒叕来了。。。应接不暇啊! %M F;`;1  
https://cwiki.apache.org/confluence/display/WW/S2-053
级别: 论坛版主
发帖
209
云币
390
只看该作者 4楼 发表于: 09-07
回 3楼(送小孩) 的帖子
心累。。。
级别: 新人
发帖
9
云币
9
只看该作者 5楼 发表于: 09-12
Re【漏洞公告】CVE-2017-9805Struts2 REST插件远程执行命令漏洞S2-052
Struts2 都快被抛弃了吧? O<PO^pi  
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个