阿里云
服务器地域选择
发表主题 回复主题
  • 1677阅读
  • 8回复

[安全漏洞公告专区]RHSA-2017:1615: kernel security and bug fix update漏洞预警及修复办法

级别: 论坛版主
发帖
1772
云币
3287

— 本帖被 不靠谱贝贝 设置为精华(2017-09-06) —
RHSA-2017:1615: kernel security and bug fix update漏洞预警及修复办法
"~|;XoMU  
今天收到了阿里的短信,说是我的一台ECS安全漏洞,吓得我赶紧去看了一下。我是不关心云盾的(其实是用不起),从云盾上次升级后,我其实也没有太在意到底变成什么样子了。 dh~ cj5  
因为下面这条消息,我不得不看看 z K+C&X  
,+Bp>=pvs  
\{RMj"w:  
提示有安全漏洞,然后点击前往云盾。 ] C&AU[U*  
当我点击下图的漏洞待处理的时候,竟然提示我要升级到企业版才能查看,心中千万头XXX奔腾。 9!kH:Az[p  
Xe J|Z)qZ  
}R\9y bv  
右上角提示可以试用云盾7天,我去,那赶紧试用看看到底是什么漏洞。开启试用,然后看到了漏洞信息 v1m'p:7uGB  
VGPBD-6)  
M;$LB@h  
如果你是一个和我一样会时常更新系统的童鞋,那么,这个地方不要盲目的点击获取修复命令,因为命令完全没有用。 yW!+:y_N_  
给出的命令是: $UX^$gG  
  1. yum update kernel-devel
waYH_)Zx  
执行后提示:No packages marked for update 5YW.s   
我们来看看细节 :-.K.Ch|:  
]JUb;B;Z  
)= :gO`"D  
上面云盾提示命中命中: kernel-devel version less than 0:3.10.0-514.26.1.el7 { yvKUTq`  
低于3.10.0-514.26.1.el7的内核版本都会命中,那只要内核版本在kernel-3.10.0-514.26.1.el7.x86_64及以上就不会有漏洞。 yOQEF\  
然后我登陆我的ECS,查看了我当前的内核版本 D{J+}*y  
  1. uname -a
-j<g}IG  
显示我的内核版本是Linux  3.10.0-514.26.2.el7.x86_64 #1 SMP Tue Jul 415:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux,已经是高于26.1了,那为什么还会有提示 H)Kt!v8  
我们再看看云盾提示信息,更多里面显示路径为/usr/src/kernels/3.10.0-514.21.2.el7.x86_64。看完这个,我就懵了,这不是旧内核版本么?没有启动也会提示漏洞? aglW\L T^  
毕竟Linux小白,不深究了,下面直接上手修复。 Z ^w5x:  
首先,修复系统是CentOS Linux release 7.3.1611 (Core),本人无其它系统。此处不做探讨。 JOA_2qa>\  
其次,要明白Centos在更新系统内核的时候,不会自动删除旧内核,会把旧内核文件留在/usr/src/kernels/这个目录里。 L 2Z9g`>  
最后,我们来上手。 (K}Md~  
1.明确自己的系统内核版本 , id`=L=  
  1. uname -sr
7ql&UIeQ  
如果版本低于Linux  3.10.0-514.26.1.el7.x86_64 ,请升级内核。此方法只说内核版本已最新,yum update提示No packages marked for update的情况。 bns([F  
2.查看旧内核版本 j+E[ [  
  1. rpm -qa|grep kernel*
AVx 0aj  
然后结果如下: potb6jc?  
'g$a.75/-  
qDPpGI-Y2e  
从上面看到了云盾提示的安全风险的内核版本 JuD$CHg;#  
kernel-3.10.0-514.21.1.el7.x86_64 02EbmP  
3.删除旧内核版本 %L^S;v3  
  1. yum remove kernel-3.10.0-514.21.2.el7.x86_64 kernel-devel-3.10.0-514.16.1.el7.x86_64 kernel-3.10.0-514.21.1.el7.x86_64 kernel-devel-3.10.0-514.21.2.el7.x86_64 kernel-3.10.0-514.16.1.el7.x86_64 kernel-devel-3.10.0-514.21.1.el7.x86_64
3XeCaq'N  
P.S.凶残的方法,直接删除所有低于26.1的旧内核。 ?pLKUAh  
4.重启系统 k/|j e~$  
  1. reboot
CL U[')H0  
5.云盾验证 R\oas"  
];|;")#=  
>;ucwLi  
z [qO5z~I  
大概5分钟左右,验证成功 X[XSf=  
0k];%HV|  
;zbF~5e  
到此,漏洞修复成功! Q>FuNdUk  
总结: ]('isq,P  
1.平时更新系统后删除旧内核吧,保留一个上一版本的内核即可。 54A ndyeA  
2.所幸新版云盾能试用七天,以后怎么办,不知道,可能世界加钱可及吧! &f\ng{  
3.总之,保持系统更新应该是没有问题的! igV4nL  
别问我以后怎么办,钱能解决的问题都不是问题! D:uBr|('  
z]NN ^pIa  
Ve4!MM@ti  
7@.UkBOx  
olC@nQ1c*  
[ 此帖被鬼才神兵在2017-09-04 23:36重新编辑 ]
本帖最近评分记录: 1 条评分 云币 +10
51干警网 云币 +10 您的帖子很精彩!希望很快能再分享您的下一帖! 09-06
本人不是云栖社区工作人员。
无论您在使用中遇到什么问题,不要出言不逊!谢谢合作!
级别: 总版主
发帖
6963
云币
15354

只看该作者 沙发  发表于: 09-05
你要有才了
级别: 论坛版主
发帖
1772
云币
3287

只看该作者 板凳  发表于: 09-06
回 1楼(梦丫头) 的帖子
何以见得呢? SG4)kQ  
自己动手丰衣足食
[ 此帖被鬼才神兵在2017-09-06 19:09重新编辑 ]
本人不是云栖社区工作人员。
无论您在使用中遇到什么问题,不要出言不逊!谢谢合作!
级别: 论坛版主
发帖
13468
云币
28775

只看该作者 地板  发表于: 09-06
您的帖子很精彩!希望很快能再分享您的下一帖!
级别: 论坛版主
发帖
13468
云币
28775

只看该作者 4楼 发表于: 09-06
Re:回 1楼(梦丫头) 的帖子
引用
引用第2楼鬼才神兵于2017-09-06 14:21发表的 回 1楼(梦丫头) 的帖子 : Q'Q^K  
何以见得呢? -LF^u;s8&S  
官方给的修复命令屁用没有…… [url=https://bbs.aliyun.com/job.php?action=topost&tid=534732&pid=1742866][/url] -Y YQnN  
U_+>4zdm  
可以说的委婉一点。
级别: 新人
发帖
1
云币
1
只看该作者 5楼 发表于: 09-09
ReRHSA-20171615kernel security and bug fix update漏洞预警及修复办法
咨询下,我的服务器内核版本:Linux 3.10.0-514.6.2.el7.x86_64 gk%nF  
需要升级内核, 但是使用命令:yum update kernel 后提示:No packages marked for update \sNgs#{7E7  
Q,3kaR@O  
这个如何操作,多谢。
级别: 论坛版主
发帖
1772
云币
3287

只看该作者 6楼 发表于: 09-17
回 5楼(小优出行) 的帖子
先uname -sr列出当前的内核版本 l5%G'1w#,j  
然后列出所有内核版本 5 hj  
删除不是当前内核版本的所有版本
本人不是云栖社区工作人员。
无论您在使用中遇到什么问题,不要出言不逊!谢谢合作!
级别: 程序猿
发帖
239
云币
374
只看该作者 7楼 发表于: 10-06
mark
级别: 新人
发帖
1
云币
1
只看该作者 8楼 发表于: 10-18
ReRHSA-20171615kernel security and bug fix update漏洞预警及修复办法
update 完运行的还是旧的内核,需要重启,重启完再检测就没问题了
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
批量上传需要先选择文件,再选择上传
 
验证问题: 阿里云官网域名是什么? 正确答案:www.aliyun.com
上一个 下一个