阿里云
服务器地域选择
发表主题 回复主题
  • 2205阅读
  • 1回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-11610:Supervisord 远程命令执行漏洞

级别: 论坛版主
发帖
183
云币
339
Supervisord是一款由Python语言开发,用于管理后台应用(服务)的工具,方便运维人员使用图形化界面进行管理。 ' 5tk0A  
近期,Supervisord曝出了一个需认证的远程命令执行漏洞(CVE-2017-11610),通过POST请求Supervisord管理界面恶意数据,可以获取服务器操作权限,存在严重的安全风险。 LeP;HP|  
具体详情如下: ou V%*<Ki  

T- ~l2u|s  
漏洞编号:   ]]"O)tWHj  
CVE-2017-11610 d-%bRGo/  
漏洞名称: L[s7q0 F`l  
Supervisord 远程命令执行漏洞 STln_'DF'  
官方评级: u([|^~H]  
高危 E!Ljq3iT`  
漏洞描述: c2E*A+V#u  
利用该漏洞远程POST请求提交Supervisord管理界面恶意数据,可以获取服务器操作权限。 }.DE521u  
漏洞利用条件和方式:   T5<851rH  
  • 利用条件:
  • Supervisor版本在受影响范围内
  • Supervisor 9001管理端口并可以被外网访问
  • Supervisor未配置密码或为弱密码
  • 利用方式:远程利用
u$M,&Om  
漏洞影响范围:   _dQg5CmlG  
  • Supervisor version 3.1.2
  • Supervisor version 3.3.2
qp##>c31X  
漏洞检测: H\vd0DD;  
开发人员查Supervisor版本是否在受影响范围内。 A.YXK%A%  
漏洞修复建议(或缓解措施):   f$y`tT %o  
1.如果不需要使用该服务软件,建议关停卸载该软件,同时检查服务器上是否存在不正常的进程、或异常账号,确保服务器运行正常; Py72:;wn  
2.如需使用该服务软件,建议卸载后,重新安装升级到官方最新3.3.3版本,重新安装前建议快照或备份数据; v w  
3.由于该漏洞利用Supervisor开放的9001管理端口发起远程攻击,阿里用户可以使用ECS安全组策略屏蔽公网入、内网入方向的9001端口; R"2wop  
4.为Supervisor配置RPC登录认证强密码,建议密码至少8位以上,包括大小写字母、数字、特殊字符等混合体。 r `;_ #&b  
情报来源:   on^m2pQ *p  
  • https://www.leavesongs.com/PENETRATION/supervisord-RCE-CVE-2017-11610.html
* a ?qV  
[ 此帖被正禾在2017-08-04 17:55重新编辑 ]
级别: 论坛版主
发帖
1764
云币
3299
只看该作者 沙发  发表于: 08-06
还好,没用过
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个