阿里云
阿里云多端小程序中小企业获客首选
发表主题 回复主题
  • 18793阅读
  • 1回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-9791:Struts(S2-048)远程命令执行漏洞

级别: 论坛版主
发帖
241
云币
478
2017年7月7日,Apache Struts发布最新的安全公告,漏洞编号为S2-048,该漏洞存在Struts2和Struts1一个Showcase插件Action Message类中,通过构建不可信的输入实现远程命令攻击,存在安全风险 x{?sn  
具体详情如下:                                                                                                      
漏洞编号: l?<q YjI  
CVE-2017-9791 ~QCA -Yud  
漏洞名称: k}s+ca!B  
Struts(S2-048)远程命令执行漏洞 o?y"]RCM  
官方评级: #<]Iz'\`  
高危 03F3q4"  
漏洞描述: 3fl7~Lw,  
Showcase插件ActionMessage类中,通过构建不可信的输入实现远程命令攻击,存在安全风险。 ZMJ3NN]F  
漏洞利用条件和方式: 1OP" 5f  
远程利用 F^miq^K=  
漏洞影响范围: U3+A MVnB  
Struts 2.3.x系列中的Showcase插件 C#h76fpH  
漏洞检测: p {?}g'  
Struts框架版本 #@E(<Pu4`  
漏洞修复建议(或缓解措施): >Fp&8p`am  
  • 根据业务情况,禁用关闭(删除) \struts-2.3.x\apps\struts2-showcase.war包
  • 建议升级到最新版本2.5.10.1
  • 阿里云盾态势感知已经支持检测
  • 阿里云云盾WAF默认支持防御,可以选用WAF防护
情报来源: {6:& %V  
  • Apache Sturts官方安全公告:HTTPS://cwiki.apache.org/confluence/display/WW/S2-048
ng 9NE8F  
oSmjs  
PU"S;4m  
Pj._/$R[/  
oc:x&`j  
{ Hr>X  
[ 此帖被正禾在2017-07-08 00:25重新编辑 ]
级别: 新人
发帖
1
云币
1
只看该作者 沙发  发表于: 2017-07-07
Re【漏洞公告】CVE-2017-9791StrutsS2-048远程命令执行漏洞
showcase插件 如何关闭?
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
批量上传需要先选择文件,再选择上传
 
验证问题: 阿里云官网域名是什么? 正确答案:www.aliyun.com
上一个 下一个
      ×
      全新阿里云开发者社区, 去探索开发者的新世界吧!
      一站式的体验,更多的精彩!
      通过下面领域大门,一起探索新的技术世界吧~ (点击图标进入)