阿里云
订阅广场
发表主题 回复主题
  • 1581阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】CVE-2017-6920:Drupal远程命令执行漏洞

级别: 论坛版主
发帖
214
云币
398
2017年6月21日,Drupal官方发布了一个编号为:CVE-2017- 6920 的漏洞,漏洞评级为Critical。该漏洞是由于DrupalCore的YAML解析器处理不当所导致的一个远程代码执行漏洞,影响8.x的DrupalCore,安全风险较高。 -mo4`F  
Drupal是使用PHP语言编写的开源内容管理框架(CMF),它由内容管理系统(CMS)和PHP开发框架(Framework)共同构成。连续多年荣获全球最佳CMS大奖,是基于PHP语言最著名的WEB应用程序。 8<KC-|y.  
具体详情如下:   /F''4%S?E  
    
C7}iwklcsa  
漏洞编号: L `=*Pwcj  
CVE-2017-6920 CyB4apJ  
漏洞名称: SJi;_bVf  
Drupal远程代码执行漏洞 hhI*2|i"L  
官方评级: D~`RLPMk  
高危 * kUb[  
漏洞描述: bxBndxl  
该漏洞是由于DrupalCore的YAML解析器在处理不安全的PHP对象句柄时,通过远程代码执行,进行高危行为操作 y&\t72C$Fi  
漏洞利用条件和方式: /q7$"wP  
远程利用 MBU4Awj  
漏洞影响范围: +%~me?  
DrupalCore8.x版本 se}$/Y}t  
漏洞检测: [ :Sl~  
登陆Drupal管理后台,查看内核版本是8.x,且版本号低于8.3.4,则存在该漏洞;否则,不存在该漏洞; ]=/?Ooh  
漏洞修复建议(或缓解措施):   ymnK`/J!Q  
  • 根治措施:目前官方已经发布了Drupal 8.3.4 修复了该漏洞,强烈建议用户升级
1|>bG#|  
  • 临时措施:升级Drupal文件“/core/lib/Drupal/Component/Serialization/YamlPecl.php”中的decode函数
6x/o j`_[  
  1. public static function decode($raw) {
  2.     static $init;
  3.         if (!isset($init)) {
  4.           // We never want to unserialize!php/object.
  5.           ini_set('yaml.decode_php', 0);
  6.           $init = TRUE;}
  7.           // yaml_parse() will error with an emptyvalue.
  8.           if (!trim($raw)) {
  9.           return NULL;
  10.           }
  11.       .....
  12.       }
  • 建议用户不要开放管理后台,避免暴力破解或web攻击直接入侵后台,同时建议用户定期更新最新版本程序,防止出现漏洞。
YhooD,[.  
情报来源: LcNI$g;}Yf  
Nd@/U c  
hAP2DeT$  
IF<T{/MA  
+@7c:CAy(  
[ 此帖被正禾在2017-06-27 13:53重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个