阿里云
订阅广场
发表主题 回复主题
  • 3103阅读
  • 0回复

[安全漏洞公告专区]【漏洞公告】“Phoenix Talon” Linux内核漏洞

级别: 论坛版主
发帖
214
云币
398
近期,Linux内核曝出远程执行漏洞,并命名为“Phoenix Talon”,其中一个漏洞为严重(Critical)级别,另外三个为高危(High)。这四个漏洞的影响范围包括所有Linux kernel 2.5.69 ~ Linux kernel 4.11的内核版本。漏洞可导致远程DOS,在符合一定利用条件下可导致远程代码执行,包括传输层的TCP、DCCP、SCTP以及网络层的IPv4和IPv6协议均受影响。 BZ zrRC  
具体详情如下:                                  /"eey(X  
                                                
漏洞编号: .C8PitS  
CVE-2017-8890 =c/wplv*  
CVE-2017-9075 {r@Ty*W} L  
CVE-2017-9076 $STaQ28C  
CVE-2017-9077 emCM\|NQg&  
漏洞名称: UK<Nj<-'t  
“Phoenix Talon” Linux内核漏洞 N5a*7EJv+  
官方评级: E\Rhz]G(  
CVE-2017-8890:严重(Critical) b )B? F  
CVE-2017-9075:高危(High) ^J$2?!~  
CVE-2017-9076:高危(High) ]H`1F1=  
CVE-2017-9077:高危(High) Ney/[3 A  
漏洞描述: O^oWG&Y;v  
CVE-2017-8890 O8h%3&  
自4.10.15版本开始Linux内核net/ipv4/inet_connection_sock.c中的inet_csk_clone_lock函数能让攻击者发动DoS(double free)攻击,或者利用accept()系统调用造成其他影响。 !\7!3$w'8,  
该漏洞是四个漏洞中最严重的,本质上是double free的问题,使用setsockopt()函数中MCAST_JOIN_GROUP选项,并调用accept()函数即可触发该漏洞。 _d5QbTe  
CVE-2017-9075 \ExMk<y_&  
4.11.1版本后的Linux内核中net/sctp/ipv6.c里的sctp_v6_create_accept_sk函数对继承处理不当,本地用户可以发动DoS攻击,或者通过特制的系统调用造成其他影响,这个漏洞与CVE-2017-8890相关。 FoN|i"*l  
CVE-2017-9076 ,yiX# ;j  
Linux版本4.11.1后的系统net/dccp/ipv6.c文件中的dccp_v6_request_recv_sock函数对继承处理不当,本地用户可以发动DoS攻击,或者通过特制的系统调用造成其他影响,这个漏洞与CVE-2017-8890相关。 x[a<mk  
CVE-2017-9077 G"h'_7  
Linux版本4.11.1后的系统net/dccp/ipv6.c文件中的tcp_v6_syn_recv_sock函数对继承处理不当,本地用户可以发动DoS攻击,或者通过特制的系统调用造成其他影响,这个漏洞与CVE-2017-8890相关。 n*2UnKaJ  
漏洞利用条件和方式: Xu%'Z".>:  
'<"s \,  
f&Gt|  
漏洞影响范围: sS*3=Yh  
Linux kernel 2.5.69 ~ Linux kernel 4.11的内核版本 8X[:j&@  
漏洞检测: 5>[u `  
F(>Np2oi6  
漏洞修复建议(或缓解措施): LY%WD%pL  
目前厂商已经发布了升级补丁以修复这些安全问题,强烈建议您使用 yum update kernel 或sudo apt-get update && sudo apt-get upgrade升级内核。 :tV*7S=)  
情报来源: 8Vr%n2M  
  • http://www.openwall.com/lists/oss-security/2017/05/30/24
2LF/H$] o5  
EV]1ml k$  
'=b/6@&  
HiZ*+T.B  
[ 此帖被正禾在2017-06-20 11:48重新编辑 ]
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个