阿里云
发表主题 回复主题
  • 10624阅读
  • 16回复

[基础常识]在阿里云ECS里使用32位真色彩显示设置

级别: 论坛版主
发帖
13395
云币
30673

云友“展悦未来”在帖子 里说,希望ECS可以设置为32位真色彩显示属性,以方便安装安卓模拟软件 。 Kw_> X&GcJ  
C{^U^>bU  
测试过程: #[=%+*Q  
csABfxib  
1. 因为公共镜像里的Windows 2008 标准版系统默认仅能以16位显示 X} <p|P+  
6_1v~#  
2. 所以,按照此帖 ,将ECS换成Windows 7系统 `_M*2(rt  
tgz  
3. 之后,Windows 7中的显示设置默认为32位真色彩 [ed6n@/O@  
N{rC#A3  
&b~if}vcb  
4. 最后,测试,可以安装逍遥安卓模拟器,但会提示OpenGL版本过低,建议升级显卡驱动程序 ':Avh|q3N  
] /w: 5o#  
(^,4{;YQ5  
C5k\RS9  
y{{7)G  
Bg3`w__l;  
o$ disJ  
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 论坛版主
发帖
3877
云币
7401
只看该作者 沙发  发表于: 2016-03-26
楼主威武
级别: 新人
发帖
7
云币
12
只看该作者 板凳  发表于: 2016-07-11
Re在阿里云ECS里使用32位真色彩显示设置
我也在尝试ECS上安装逍遥安卓游戏,安装成功,电脑运行失败,由于ECS上不支持显卡,提示openGL版本太低。 K]0Q=HY{.  
请问楼主是怎么解决的啊??
级别: 论坛版主
发帖
13395
云币
30673

只看该作者 地板  发表于: 2016-07-11
回 2楼(zhlask) 的帖子
您好, ]]EOCGZ"  
K KCzq |  
请问您安装的程序版本是什么呢? 8Hdm(>  
Oi?+Z:lak  
例子中的是 2.5 版本。不确定新版本是否会因为检测到ECS的OpenGL版本过低而停止运行喔。
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 新人
发帖
7
云币
12
只看该作者 4楼 发表于: 2016-07-11
回 3楼dongshan8的帖子
Hello~ 楼主好 Uyuvmt>  
e2}5< 7  
        我使用的MEmu版本是2.6.5,在ECS上安装时成功的,但是只能运行到59%就不能继续了,一直停在59%的状态,应该是因为检测到openGL版本太低的缘故。 ~+HZQv3Y  
MEmu2.5版本完全可以在ECS上运行吗?  还是只是安装成功而已。
级别: 论坛版主
发帖
13395
云币
30673

只看该作者 5楼 发表于: 2016-07-12
回 4楼(zhlask) 的帖子
您好, 3E2.v5*  
9QM"JEu@  
那我找个测试机,为您再次测试一下。
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 新人
发帖
7
云币
12
只看该作者 6楼 发表于: 2016-07-12
回 5楼dongshan8的帖子
TXOW/{B  
          非常感谢!!! EQ`t:jc {  
V$F.`O!hfi  
     我用的ECS版本是windows server 2012 ,显示适配器是:Microsoft Basic Display Adapter,是不支持显卡的。
级别: 论坛版主
发帖
13395
云币
30673

只看该作者 7楼 发表于: 2016-07-12
回 6楼(zhlask) 的帖子
您好, J,CJPUf&  
mMel,iK=  
为您在Windows 2012及Windows 7中测试新版本MEmu,均是在启动约59%后停止一段时间后提示启动失败。 E|KLK4 ]  
I|Vk.,  
然后我根据别人的提示,安装了另一款,叫“靠谱助手”的软件,安装成功,但在安装应用时,提示安装Bluestacks的模拟器,但安装模拟器的过程中提示显卡驱动未安装。 %iHyt,0v2  
JrY"J]/  
所以,可能回到了“老问题”,即ECS是虚拟化出来的,且是没有类似家里的电脑那样有高级显示处理能力的喔。 oVKsic?  
8#[%?}tK  
K * xM[vO  
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 新人
发帖
7
云币
12
只看该作者 8楼 发表于: 2016-07-12
回 7楼dongshan8的帖子
C}P \kDM  
ks#Z~6+3  
      感谢版主百忙之中为我测试。这样看来我们尝试的结果是一样的。 ~h^}W$pO  
} @fu~V/  
还想问下,有没有软件模拟的方式升级Opengl 版本,类似于模拟显卡。我使用的ECS中DirectX版本是11。 ,nChwEn  
On.x~ t  
v yLAs;  
级别: 论坛版主
发帖
13395
云币
30673

只看该作者 9楼 发表于: 2016-07-13
回 8楼(zhlask) 的帖子
您好, ,}:}"cl  
4Ifz-t/  
从OpenGL官方的介绍来看,可能默认最高是1.1版本了: tNG[|Bi#  
odTa 2$O  
引用
Without drivers, you will default to a software version of OpenGL 1.1 (on Win98, ME, and 2000), a Direct3D wrapper that supports OpenGL 1.1 (WinXP), or a Direct3D wrapper that supports OpenGL 1.1 (Windows Vista and Windows 7). None of these options are particularly fast, so installing drivers is always a good idea.
TZ#^AV=ae  
提到升级OpenGL版本的方法是升级相应显卡的驱动,但具体到ECS,暂时没有发现更佳的驱动。可能这是因为ECS是专用于后台服务,并没有如家里用的普通电脑那样有较好的显示处理能力。 SajasjE!^1  
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 新人
发帖
2
云币
8
只看该作者 10楼 发表于: 2017-07-07
Re在阿里云ECS里使用32位真色彩显示设置
能不能出一个安卓的X86镜像,方便挂游戏用啊,阿里云又不支持上传镜像,请问版主的WIN7镜像是哪里找的
级别: 论坛版主
发帖
13395
云币
30673

只看该作者 11楼 发表于: 2017-07-07
回 10楼(开车老司机) 的帖子
您好, DSyXr~p8  
jgu*Y{ocm  
欢迎来到阿里云论坛。 !!,0'c  
! fl4"  
例子中的Windows 7镜像是自己通过iso文件安装的喔。 /bVZ::A&_  
>,5i60Q  
挂游戏,可能在自己家里的电脑挂,比较方便吧。
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 新人
发帖
1
云币
2
只看该作者 12楼 发表于: 2017-11-30
Re在阿里云ECS里使用32位真色彩显示设置
你好 我想问一下 安装完模拟器之后能正常玩游戏么?
级别: 论坛版主
发帖
13395
云币
30673

只看该作者 13楼 发表于: 2017-11-30
回 12楼(醉酒青牛123) 的帖子
版主回复: qH(2 0Z!  
k'\RS6M`L  
在这个例子里,应该不能玩游戏,因为“逍遥安卓模拟器”虽然能安装,但不能成功运行。
Debian 是一个自由的操作系统 (OS),提供您安装在计算机上使用。操作系统就是能让您的计算机工作的一系列基本程序和实用工具。
级别: 架构狮
发帖
1240
云币
2018
只看该作者 14楼 发表于: 01-25
您的帖子很精彩!希望很快能再分享您的下一帖!
发表主题 回复主题
« 返回列表
«12»
共2页
上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: 阿里云官网域名是什么? 正确答案:www.aliyun.com
上一个 下一个