阿里云
阿里云多端小程序中小企业获客首选
发表主题 回复主题
  • 286748阅读
  • 527回复

阿里云LNAMP(Linux + Nginx + Apache + MySQL + PHP)环境一键安装脚本

级别: 论坛版主
发帖
3273
云币
10681
* 我签名里的QQ不免费解决或者解答任何问题,加之前请看清楚。 B]m@:|Q  
* 这个脚本可以在阿里上正常安装,在不错误修改配置文件和不安装其他冲突软件的情况下可以正常运行使用,所以,在修改配置文件和安装其他软件的时候请考虑清楚后果,本帖里无法提供这方面的协助。 GoA4f3  
GRb*EeT  
IDkWGh  
简单说明: u p.Q>28r  
使用这个脚本可以动化安装Nginx(处理前端静态请求), Apache(作为后端处理PHP请求), MySQL, PHP,FTP等Linux系统必需的服务环境。 ~$' \L  
支持CentOS,Debian和Ubuntu的所有主流版本(测试过的版本包括CentOS-5.9-i386, CentOS-5.9-x86_64, CentOS-6.4-i386, CentOS-6.4-x86_64, Debian-6-32bit, Debian-6-64-bit, Debian-7-32bit, Debian-7-64-bit, Ubuntu-10-32bit, Ubuntu-10-64bit, Ubuntu-11-32bit, Ubuntu-11-64bit, Ubuntu-12-32bit, Ubuntu-12-64bit, Ubuntu-13-32bit, Ubuntu-13-64bit) F:*W5xX  
RZM"~ 0  
为什么要用LNAMP? }I 3gU  
如果使用LNMP,也就是以php-fpm方式跑PHP,稳定性欠佳,经常遇到的错误如:Nginx 502 Bad Gateway。 0TfS=scT  
如果使用LAMP,Apache在处理前端HTTP请求时的效率要比Nginx低非常多。 IG(?xf\C  
以Nginx Apache方式运行网站程序则可以充分利用这二者的优势:Nginx的高效和Apache的稳定。 o,U9}_|A  
FX9F"42@  
并且,本程序会根据不同的主机硬件情况自动优化服务器软件配置参数,充份利用主机资源。 {x'GJtpb  
2*(Z==XC7  
由于不同的网站程序可能会对PHP版本有要求,比如,有些网站程序只能运行在PHP5.2下。 所以,本安装脚本提供定制安装指定版本的PHP,支持的版本包括,PHP5.2、PHP5.3、PHP5.4、PHP5.5共四个版本。具体的安装方法请见后文。 NCxqh<  
 `:P  
安装步骤: iXyO(w4D  
* 注意:如果主机上已经通过任何其他方式安装了服务器环境,请在使用本脚本前,重装系统!(注意备份数据) 5H=ko8fZ=  
J]m{ b09F  
(1)安装screen和python命令 qB)"qFa  
由于安装脚本是使用Python语言编写的,所以需要安装python命令才能执行。 fc/ &X  
同时,为了防止安装过程中出现SSH掉线的问题,建议先安装screen命令工具。 2H.654  
CentOS系统下的安装方法为: v9Xp97J2  
yum install -y screen )p!7 #v/@f  
(CentOS系统基本都已经安装了python命令,无需再次安装,因为yum本身就是Python程序。 Bo<>e~6P  
Debian和Ubuntu系统下的安装方法为: 'J,T{s1J  
apt-get install -y screen python vG \a1H  
Hm+ODv9  
(2)建立screen窗口 `ptj?6N-  
安装screen后使用下面的命令开启一个screen窗口: >A0k 8T  
screen -S lnamp gM [w1^lj  
后面的所有操作都在这个screen窗口中进行。 gN)c  
如果安装途中由于网络问题导致SSH连接掉线,那么可以重新连接SSH后,用下面的命令打开安装窗口: P2nft2/eu?  
screen -x lnamp -P&6L\V  
M$0u1~K  
(3)安装LNAMP W8lx~:v  
上面的准备工作结束后开始正式安装LNAMP。 k`GA\&zt  
输入下面的命令,然后安装脚本将会自动安装LNAMP环境。 3!5Ur&  
wget -O - http://www.server110.com/lnamp/ | python rP!#RzL  
安装结束后,会在屏幕显示服务器帐号密码信息。同时这些信息会保存在/root/setup.txt,方便日后查看。 WK="J6K5  
8k(P,o  
自定义PHP版本: 4t)%<4  
安装脚本默认情况下会安装PHP5.2(with ZendOptimizer 3.3.9 and XCache),一般情况下,没有必要修改。 >J|]moSVA  
如果网站程序的说明文档里对运行环境的PHP版本有其他要求,比如一定要在PHP5.3下才能运行,那么就需要安装对应的PHP版本了。 {O|'U'  
本安装脚本可支持的PHP版本有:5.2(默认)、5.3、5.4、5.5。 wvrrMGU)a  
以指定安装PHP5.3为例,需要使用下面的命令参数: -l%J/:  
wget -O - http://www.server110.com/lnamp/ | python - -p 5.3 *D'$"@w3  
XQ4G)  
"B_K XL  
PS,wordpress用户请不要使用5.2,详情见: ;<0LXYL;  
http://bbs.aliyun.com/read/164642.html QdLYCR4f  
V138d?Mm  
iS5W>1]  
添加站点: zni)<fmju  
* 注意:操作过程中需要输入的内容已经用红框圈出。 :>itXD!  
P ~PIMkt  
(1)输入site命令,提示选择需要的操作,输入数字1,然后回车。 31EyDU,W  
;/j= Ny{9  
&K/FyY5  
(2)输入网站要使用的目录,比如这里输入的为'server110.com',那么网站将使用的目录全路径为'/home/www/server110.com'。 "_2Ng<2  
8u!"#S#>a  
Jv.U Q  
(3)输入需要绑定的域名,注意不要带'www.',比如输入'server110.com',程序会自动把'www.server110.com'这个域名也给绑定上,这个域名就不需要我们输入了。 iMfngIs |  
!?^b[ nC%  
3=W!4  
绑定域名后,程序会自动重载Nginx和Apache的配置,以使绑定生效。 !Ci~!)$z6  
^<X@s1^#  
经过上面这些操作后,程序会将'server110.com','www.server110.com', 'server110.net','www.server110.com'这四个域名绑定在'/home/www/server110.com'这个目录上。 OLI$1d_  
sl2@umR7%(  
由于安全原因,使用www这个用户登录FTP时活动范围被限制在了'/home/www/'这个目录下,我们在FTP里看到的'server110.com'这个目录,实际在系统里的完整路径即为'/home/www/server110.com/',把网站程序上传到'server110.com'这个目录即可。如下图: QJ|ap4r  
>AJSqgHQ,  
v:+ ~9w+  
XT;u<aJs  
-R{V-   
其他常用使用帮助: udeoW-_  
LNAMP环境管理教程目录 WoxwEi1~0  
*'"^NSJ  
;;A2!w{}[i  
vky.^  
." $  
]jpu,jz:  
HNL42\Kz!  
Y'e eA 2O  
[ 此帖被服务器之家在2014-09-17 12:11重新编辑 ]
本帖最近评分记录: 16 条评分 云币 +21
beatricezeng 云币 +1 我在一键安装lnamp的时候,输入代码结果出现一个404 not found怎么办呢? 2015-08-06
vicy 云币 +1 - 2014-12-08
口罩下的笑 云币 +1 这个要mark 一下 2014-12-03
work53 云币 +1 互联军事http://www.com9g.cn/ 2014-12-02
supper勇 云币 +1 您的无私奉献精神值得我们学习!向您致敬! 2014-11-04
mebeber 云币 +1 AI NI 2014-11-03
wide 云币 +1 您的帖子很精彩!希望很快能再分享您的下一帖! 2014-10-04
asky8 云币 +1 赞一个 2014-08-27
西贝庄 云币 +1 优秀文章-欢迎进行技术分享,感谢你的支持! 2014-08-17
187460535593397 云币 +1 谢谢 http://bbs.shoujifans.com 2014-07-15
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 论坛版主
发帖
3273
云币
10681
只看该作者 置顶  来自2楼 发表于: 2014-02-14
— (服务器之家) 执行 帖内置顶 操作 (2014-02-14 15:28) —
FAQ: W[+|}  
q64k7<C,  
LNAMP是不是比LNMP更费内存? fh^lO ^  
LNAMP中处理PHP程序的是Apache,LNMP处理PHP程序的是PHP-FPM,这二者占用的内存是差不多的。 -R>}u'EG>  
#Km:}=  
LNAMP为什么会比LNMP更稳定? P=1I<Pew  
原因同上,Apache是全世界流行了十几年的服务器程序,稳定性自然不在话下,而PHP-FPM是以PHP解释器引擎本身添加进了“服务器”的功能特性实现的,尤其在大负载情况下差异更为突出。 z6py"J@  
7Ol}EPf#  
LNAMP为什么会比LAMP更高效? RmrL^asg  
LNAMP中处理静态请求的是NGINX,LAMP中处理静态请求的是APACHE。 q$G,KRy/  
NGINX主要是以多线程的方式工作的,也就是它只需要一个进程,就可以处理大量的并发请求。而APACHE是以进程的方式工作,每处理一个请求,就需要占用一个进程。进程和线路的区别应该不需要多解释了。 ~ 8aJ S,u  
APACHE也可以使用线程的方式,但是这样的话,它处理PHP解析也会同样使用多线程,流量稍高点的环境中会严重影响稳定性。 eiJ2NwR\w  
>MJg ,  
为什么不带面板? [31p&FxM  
原因1:本人不擅长写WEB程序。 b|z g<  
原因2:任何带有面板的环境套件,对环境本身的修改都有很大的限制,比如流量达到几万IP的时候,你再想优化下环境,一旦有些配置你修改了,就可能会导致面板出问题。 ,#W  
[ 此帖被服务器之家在2014-06-10 10:02重新编辑 ]
本帖最近评分记录: 1 条评分 云币 +1
asky8 云币 +1 必须赞! 2014-08-27
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 科学怪人
发帖
9441
云币
14683
只看该作者 沙发  发表于: 2014-02-14
看起来很牛逼的样子
级别: 论坛版主
发帖
3273
云币
10681
只看该作者 板凳  发表于: 2014-02-14
— (服务器之家) 执行 帖内置顶 操作 (2014-02-14 15:28) —
FAQ: w<9>Q1(  
yk2!8  
LNAMP是不是比LNMP更费内存? :Sg_t Of  
LNAMP中处理PHP程序的是Apache,LNMP处理PHP程序的是PHP-FPM,这二者占用的内存是差不多的。 l8K5k:XCU3  
$N2SfyX7  
LNAMP为什么会比LNMP更稳定? FI8Oz,  
原因同上,Apache是全世界流行了十几年的服务器程序,稳定性自然不在话下,而PHP-FPM是以PHP解释器引擎本身添加进了“服务器”的功能特性实现的,尤其在大负载情况下差异更为突出。 '2zL.:~  
Z['\61  
LNAMP为什么会比LAMP更高效? g fU-"VpHE  
LNAMP中处理静态请求的是NGINX,LAMP中处理静态请求的是APACHE。 h;lirvO|  
NGINX主要是以多线程的方式工作的,也就是它只需要一个进程,就可以处理大量的并发请求。而APACHE是以进程的方式工作,每处理一个请求,就需要占用一个进程。进程和线路的区别应该不需要多解释了。 #<( = }?  
APACHE也可以使用线程的方式,但是这样的话,它处理PHP解析也会同样使用多线程,流量稍高点的环境中会严重影响稳定性。 dMx4ykrR  
Fyyg`J  
为什么不带面板? Ut]+k+ 4  
原因1:本人不擅长写WEB程序。 0^'B3$>  
原因2:任何带有面板的环境套件,对环境本身的修改都有很大的限制,比如流量达到几万IP的时候,你再想优化下环境,一旦有些配置你修改了,就可能会导致面板出问题。 8&"(WuZ@  
[ 此帖被服务器之家在2014-06-10 10:02重新编辑 ]
本帖最近评分记录: 1 条评分 云币 +1
asky8 云币 +1 必须赞! 2014-08-27
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 码农
发帖
214
云币
236
只看该作者 地板  发表于: 2014-02-14
Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
看起来挺好的样子
级别: 小白
发帖
5
云币
5
只看该作者 4楼 发表于: 2014-02-14
Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
落伍的兄弟啊,支持了
级别: 菜鸟
发帖
35
云币
57
只看该作者 5楼 发表于: 2014-02-14
Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
支持呀,今天就试试
级别: 论坛版主
发帖
4952
云币
16507
只看该作者 6楼 发表于: 2014-02-15
你是我偶像
级别: 技术砖家
发帖
1002
云币
2975
只看该作者 7楼 发表于: 2014-02-15
级别: 新人
发帖
14
云币
18
只看该作者 8楼 发表于: 2014-02-15
Re
以后可以考虑升级脚本,比如升级php,nginx等
级别: 论坛版主
发帖
3273
云币
10681
只看该作者 9楼 发表于: 2014-02-15
Re:Re
引用
引用第8楼imhua于2014-02-15 23:27发表的 Re : g}og@UY7#  
以后可以考虑升级脚本,比如升级php,nginx等 $=g.-F% *=  
^)P5(fJ  
在计划中
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 小白
发帖
2
云币
2
只看该作者 10楼 发表于: 2014-02-16
Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
安装过程有错误 L5|;VH  
make[2]: *** No rule to make target `/usr/lib/libcurses.so', needed by `client/mysql'.  Stop. D@ 1^:'$V  
make[1]: *** [client/CMakeFiles/mysql.dir/all] Error 2 VqT[ca\  
make: *** [all] Error 2 z8[|LF-dx  
kk./-G  
Error Occured! 2o3k=hKS  
-+2xdLa63  
Current Work Dir: M]zNW{Xt  
/tmp/dir/mysql-5.5.36 -OGy-"  
Command: 8i$`oMv[y  
make -j 1 && make install
级别: 论坛版主
发帖
3273
云币
10681
只看该作者 11楼 发表于: 2014-02-16
Re:Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
引用
引用第10楼xinde于2014-02-16 10:23发表的 Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本 : yt,;^o^  
安装过程有错误 y5h[^K3  
make[2]: *** No rule to make target `/usr/lib/libcurses.so', needed by `client/mysql'.  Stop. f/m6q8!L{  
make[1]: *** [client/CMakeFiles/mysql.dir/all] Error 2 >*CK@"o  
make: *** [all] Error 2 W<l(C!{  
``Rb-.Fq,  
....... 11+_OC2-   
x*V<afLY[  
NWj@iyi<  
发行版,版本号,位数,这些能否提供下? )Cfrqe1^  
方便的话最好能PM下IP和密码。 CgE5;O  
Xpwom'  
5)6%D  
错误是因为缺少libcurses这个库,不同的系统里名字可能会不一样。
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 小白
发帖
2
云币
2
只看该作者 12楼 发表于: 2014-02-16
Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
就是阿里云主机,5.8 64位,重置系统后,安装的这个软件包,选择php5.4版本,无其他!
级别: 小白
发帖
1
云币
1
只看该作者 13楼 发表于: 2014-02-16
Re阿里云LNAMPLinuxNginxApacheMySQLPHP环境一键安装脚本
ln: creating symbolic link `/usr/bin/resolve_stack_dump': File exists V ;jz0B  
/usr/local/mysql/bin/mysqladmin: connect to server at 'localhost' failed Z ngJ9js  
error: 'Access denied for user 'root'@'localhost' (using password: NO)' = @o}  
566Qik w2  
Error Occured! lH.2H  
HxaUVg0  
Current Work Dir: g_U69 z  
/tmp/dir TZg7BLfy  
Command: KG$2u:n  
/usr/local/mysql/bin/mysqladmin -u root password wrCF8xIn u7d]%<~'$F  
在是什么错误,怎么处理? }__+[-  
php-5.5.9.tar.gz 官方源太慢了,更换国内镜像吧
发表主题 回复主题
« 返回列表
«12345678910»
共36页
上一主题下一主题
×
全新阿里云开发者社区, 去探索开发者的新世界吧!
一站式的体验,更多的精彩!
通过下面领域大门,一起探索新的技术世界吧~ (点击图标进入)