阿里云
发表主题 回复主题
  • 2134阅读
  • 4回复

node-v6.11.3 用不了短信的SDK

级别: 新人
发帖
1
云币
2


提示下面错误,是不是因为这个node版本不支持async








Unexpected identifier





d:\Nodejs\workspace\djorient\node_modules\@alicloud\sms-sdk\index.js:51async _getMNSClient(type) {^^^^^^^^^^^^^SyntaxError: Unexpected identifierat createScript (vm.js:56:10)at Object.runInThisContext (vm.js:97:10)at Module._compile (module.js:542:28)at Object.Module._extensions..js (module.js:579:10)at Module.load (module.js:487:32)at tryModuleLoad (module.js:446:12)at Function.Module._load (module.js:438:3)at Module.require (module.js:497:17)at require (internal/module.js:20:19)at Object._sendSMS [as sendSMS] (d:\Nodejs\workspace\djorient\unit\vcode.js:6:23)at d:\Nodejs\workspace\djorient\routes\sendSMS.js:8:11at Layer.handle [as handle_request] (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\layer.js:95:5)at next (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\route.js:137:13)at Route.dispatch (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\route.js:112:3)at Layer.handle [as handle_request] (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\layer.js:95:5)at d:\Nodejs\workspace\djorient\node_modules\express\lib\router\index.js:281:22at Function.process_params (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\index.js:335:12)at next (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\index.js:275:10)at Function.handle (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\index.js:174:3)at router (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\index.js:47:12)at Layer.handle [as handle_request] (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\layer.js:95:5)at trim_prefix (d:\Nodejs\workspace\djorient\node_modules\express\lib\router\index.js:317:13)
关键词: 错误 SDK
级别: 新人
发帖
1
云币
1
只看该作者 沙发  发表于: 2017-09-20
Renode-v6.11.3 用不了短信的SDK
我也是一样的问题,nodejs V6.11.3,现在正在升级nodejs v8,我也是无语了,一个SDK兼容性这么差!!! 没人吐槽这点吗?
级别: 新人
发帖
1
云币
1
只看该作者 板凳  发表于: 2017-09-26
Renode-v6.11.3 用不了短信的SDK
我也碰见这个问题了  v6.11.0  版本  ,  正打算升级node 版本
级别: 新人
发帖
1
云币
1
只看该作者 地板  发表于: 01-11
Renode-v6.11.3 用不了短信的SDK
我现在版本比v8更高了,还是不行?
PS D:\Apps\nodejs> npm -v
5.5.1
PS D:\Apps\nodejs> node -v
v9.2.1

\node_modules\@alicloud\sms-sdk\index.js:51 Uncaught SyntaxError: Unexpected identifierexports.runInThisContext @ vm.js:76Module._compile @ module.js:528Module._extensions..js @ module.js:565Module.load @ module.js:473tryModuleLoad @ module.js:432Module._load @ module.js:424Module.require @ module.js:483require @ internal/module.js:20(anonymous function)
级别: 新人
发帖
2
云币
3
只看该作者 4楼 发表于: 01-31
Renode-v6.11.3 用不了短信的SDK
有人看一下吗?
我也碰到了这个问题node 6.10 npm 4

官方SDK怎么做的这么烂啊
发表主题 回复主题
« 返回列表上一主题下一主题

限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
验证问题: 83 - 69 = ?
上一个 下一个