阿里云
阿里云多端小程序中小企业获客首选
发表主题 回复主题
  • 33407阅读
  • 33回复

最近wordpress后台或者安装出现502错误的用户请注意

级别: 论坛版主
发帖
3273
云币
10681
— 本帖被 服务器之家 执行取消置顶操作(2014-08-11) —
很多人看帖子马马虎虎,我再强调一下,本帖适用的情况 pE.TG4  
只有安装页面和后台部分页面出现502错误,其他页面正常。 Nfmr5MU_  
vJb/.)gh]  
w+XwPpM0.n  
这个问题的产生是由于PHP解析进程出现Segmentation fault错误进而导致的nginx的502错误。 ]tmMk7  
*nV"X0&  
6O*lZNN  
目前已知的会出现这一错误的组合为: NezE]'}  
CentOS 6.x系统+PHP5.2+最新版的WordPress程序 (/!zHq  
其他的组合没有写不代表不会出现 }%0X7'  
nu[["f~  
z|$9%uz"  
解决的办法有二个,可以任选其一: y%<CkgZS  
1)把CentOS更换为其他系统 (!9+QXb'  
2)把PHP升级到5.3或者以上 qGP}  
!3z ;u8W  
l}D /1~d  
再补充下,在LNMP和LNAMP环境中,显示的错误是502。 `9acR>00$  
而在LAMP环境中,由于处理HTTP请求和PHP解析的都是APACHE进程,进程挂掉后会显示服务器无法连接之类的错误。 +IlQZwm~  
*\`<=,H6<  
UM^~a$t  
hsYv=Tw3C  
[ 此帖被服务器之家在2014-08-11 19:21重新编辑 ]
本帖最近评分记录: 2 条评分 云币 +5
dt_27 云币 +1 太感谢了,困扰了我好几个月的问题。。。终于解决了,感谢! 2014-12-22
holdb 云币 +4 您的帖子很精彩!希望很快能再分享您的下一帖! 2014-08-11
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 攻城狮
发帖
619
云币
500
只看该作者 沙发  发表于: 2014-07-22
感谢分享啊,高手
级别: 码农
发帖
196
云币
322
只看该作者 板凳  发表于: 2014-07-22
Re最近wordpress后台或者安装出现502错误的用户请注意
向高手学习,向高手致敬!
级别: 科学怪人
发帖
9985
云币
21878

只看该作者 地板  发表于: 2014-07-22
wordpress 502的原因还是很多的,已知在centos 5.X 32位系统上以及PHP5.3都出现过。 32`Z3-  
各种蛋疼的502,目前推荐用php5.3 加上apache 跑wordpress 较稳定。内存较小的阿里云推荐mysql5.1X版本。
[ 此帖被kideny在2014-07-22 14:12重新编辑 ]
级别: 论坛版主
发帖
3273
云币
10681
只看该作者 4楼 发表于: 2014-07-22
引用
引用第3楼kideny于2014-07-22 14:11发表的  : 4=;j.=>0X  
wordpress 502的原因还是很多的,已知在centos 5.X 32位系统上以及PHP5.3都出现过。 1LAd5X  
各种蛋疼的502,目前推荐用php5.3 加上apache 跑wordpress 较稳定。内存较小的阿里云推荐mysql5.1X版本。 1&<o3)L:  
#kA?*i[T  
对于理解能力不行的人,字体再大颜色再红也没有用。 k GYsjhL\d  
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 科学怪人
发帖
9441
云币
14683
只看该作者 5楼 发表于: 2014-07-22
多谢提醒
级别: 荣誉会员
发帖
2253
云币
2409
只看该作者 6楼 发表于: 2014-07-23
请问楼主提供的 lnamp 环境有没有更新php的版本啊?
级别: 论坛版主
发帖
3273
云币
10681
只看该作者 7楼 发表于: 2014-07-23
引用
引用第6楼vpsmm于2014-07-23 00:24发表的  : -;_"Y]#  
请问楼主提供的 lnamp 环境有没有更新php的版本啊? |w*s:p  
ZJ)Z  
p$1 'e,G  
安装可以指定次版本号,修正版本号是在PHP官网页面分析出最新的。
本人非阿里云员工,所有言论不代表阿里云公司观点。
有偿提供:环境安装、配置、优化,数据迁移,安全加固,攻击防护,故障排除,长期代维等技术服务。
级别: 码农
发帖
101
云币
49
只看该作者 8楼 发表于: 2014-07-23
Re最近wordpress后台或者安装出现502错误的用户请注意
很不错哦,一般web服务器的系统用linux吧。
级别: 程序猿
发帖
303
云币
-2
只看该作者 9楼 发表于: 2014-07-24
占楼啦
级别: 小白
发帖
6
云币
7
只看该作者 10楼 发表于: 2014-07-26
Re最近wordpress后台或者安装出现502错误的用户请注意
我有台低配的ECS(1核512M内存),上面跑的MySQL5.6.19+php5.5.9+nginx1.6.0+最新的wordpress。目前还没有什么问题,一切正常。站点地址 www.xiaomastack.com 多多关照
级别: 菜鸟
发帖
75
云币
94
只看该作者 11楼 发表于: 2014-07-27
Re最近wordpress后台或者安装出现502错误的用户请注意
感谢,PHP升级后,没出现502了
级别: 小白
发帖
3
云币
53
只看该作者 12楼 发表于: 2014-07-28
Re最近wordpress后台或者安装出现502错误的用户请注意
我的后台动不动就403
级别: 攻城狮
发帖
688
云币
532
只看该作者 13楼 发表于: 2014-07-28
Re最近wordpress后台或者安装出现502错误的用户请注意
最近更新文章也频繁出现502
级别: 小白
发帖
1
云币
1
只看该作者 14楼 发表于: 2014-07-30
Re最近wordpress后台或者安装出现502错误的用户请注意
不用 wp, GfP'  
抛弃 wp, 投入 go,nodejs. En-=z`j G  
不要问加什么,\ gJwX  
! Y UT*  
请叫我雷锋
发表主题 回复主题
« 返回列表
«123»
共3页
上一主题下一主题

限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
验证问题: ECS是阿里云提供的什么服务? 正确答案:云服务器
上一个 下一个
      ×
      全新阿里云开发者社区, 去探索开发者的新世界吧!
      一站式的体验,更多的精彩!
      通过下面领域大门,一起探索新的技术世界吧~ (点击图标进入)